Supported Browsers

The Screenly web app uses advanced functionality present in modern web browsers. Please use the latest version of Chrome, Firefox, Internet Explorer >10 or Safari to make sure all features work as intended.

Have more questions? Submit a request

0 Comments

Article is closed for comments.